What devices can run Onside?

Supported iOS and Android versions

We're constantly hard at work, improving Onside. To make the most of the latest improvements and features we release, we recommend keeping Onside as up-to-date as possible. Sometimes this also means we can no longer support old versions of Android or iOS.

Devices we support (App)

We fully support the app on: Android 8.1, 9, 10, 11 - iOS 12, 13, 14.

May run Onside, but not recommended: Android 7, 8.0 - iOS 10, 11 -  iPadOS

Devices we no longer support: Android 6 or earlier - iOS 9 and earlier.
Web browsers we support (Web Portal and Kiosk)
We fully support: latest version of Chrome on Windows, Mac, iOS, Android.

Note - You may be able to use other browsers or older versions. However, we recommend you update to the latest versions to get the best experience.

What does this mean?

It means that older Android devices (running Android 7 or 8.0) and iPhones (running iOS 10 & 11) will still be able to use Onside, but updates, patches, and bug fixes will not be released on their respective stores.

Why does support end for older versions?

As Apple and Google no longer supports software versions and devices, in order to keep Onside current and secure, we follow their advice. When Google and Apple drop support for a version or device, they stop patching security holes, leaving you vulnerable. Our customers trust us to be secure and to do that, the device our app runs on needs to be supported.

Do I have the latest version of Onside?

To find if out you have the the latest version of the Onside app, it's best to go directly to the Onside app in the App Store or Play Store, as we typically release a new update a few times a month.


If you have any questions or need help, feel free to contact us on 0800 ONSIDE or at help@onside.co.nz.